summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDarrick J. Wong <djwong@kernel.org>2023-12-04 18:43:31 -0800
committerKent Overstreet <kent.overstreet@linux.dev>2023-12-07 11:57:36 -0500
commit74753de9894df00b8759f5cd6909335e268b0035 (patch)
tree6905f48e27190a81c7c5993bbb0871fd4f7f8729 /debian
parentfbfdd05ac5b5b748cf9c7c0ea72be5268917c5d6 (diff)
fsck: add a service to schedule and run bcachefsck@ services
Create a script that looks for mounted bcachefs filesystems and tries to run as many of them in parallel as possible without two different scrubbers hitting the same low level block device. Signed-off-by: Darrick J. Wong <djwong@kernel.org>
Diffstat (limited to 'debian')
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules2
2 files changed, 3 insertions, 3 deletions
diff --git a/debian/control b/debian/control
index 2e7c86b2..e68bd7ab 100644
--- a/debian/control
+++ b/debian/control
@@ -6,12 +6,12 @@ Standards-Version: 3.9.5
Build-Depends: debhelper (>= 9), pkg-config, libaio-dev, libblkid-dev,
libkeyutils-dev, liblz4-dev, libsodium-dev, liburcu-dev, libudev-dev,
libzstd-dev, uuid-dev, zlib1g-dev, python3, python3-docutils,
- rustc, cargo, llvm, clang, libclang-dev
+ rustc, cargo, llvm, clang, libclang-dev, systemd
Homepage: https://bcachefs.org/
Package: bcachefs-tools
Architecture: linux-any
-Depends: ${shlibs:Depends}, ${misc:Depends}
+Depends: ${shlibs:Depends}, ${misc:Depends}, ${python3:Depends}
Recommends: initramfs-tools | linux-initramfs-tool
Description: bcachefs userspace tools
Userspace tools for bcachefs, a modern copy on write, checksumming, multi
diff --git a/debian/rules b/debian/rules
index ae98f5ce..7a713efb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,7 @@
PREFIX := /usr
%:
- dh $@
+ dh --with python3 $@
override_dh_auto_install:
dh_auto_install -- "PREFIX=$(PREFIX)"