summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorAustin Seipp <aseipp@pobox.com>2017-11-26 00:20:14 -0600
committerAustin Seipp <aseipp@pobox.com>2017-12-10 16:07:33 -0600
commitfa36882a73fbb3fd771c506641a1d70d51c07068 (patch)
tree2e134083de656af6ebb7419302b274fad188c0eb /default.nix
parent997bb216aa37010826067d0cfa33b4fde5aaa225 (diff)
nix: add nix expressions for development
This adds Nix expressions for bcachefs-tools that are modular, work in purely sandboxed build environments (e.g. on NixOS itself, or macOS, where sandboxing is enabled by default), use a fixed copy of Nixpkgs (to avoid hidden, global state) and uses standard build idioms. This change uses a fixed version of Nixpkgs, one that will always be used for every build of bcachefs-tools, for all users, rather than relying on whatever copy of Nixpkgs the user has available. This has a major benefit in that it allows the build to work in sandboxed environments such as NixOS, and it correctly declares all of the necessary dependencies that bcachefs-tools needs. This is done simply by using stdenv.mkDerivation in order to write a "normal" Nix expression, where the previous version used a variant of the stdenv builder, but this isn't needed for the most part. (Doing this has other knock-on benefits, such as the usage of standardized options like `enableParallelBuild = true;` -- allowing `nix-build` to automatically do parallel builds, etc.) Another major benefit of this change is that anyone can now use `nix-shell` to develop/hack on bcachefs-tools incrementally; simply running nix-shell will put you in a Bash shell environment where all of bcachefs-tools' dependencies are proprerly provided, no matter the state of the outside build environment/host operating system: $ nix-shell [nix-shell:~/src/bcachefs-tools]$ make -j4 # works immediately As mentioned before, with this change, by default, nix-build and nix-shell run using a prepackaged copy of an upstream Nixpkgs snapshot. This is done purely to ensure anyone who builds bcachefs-tools using Nix does, in fact, get a reproducible build. Without this, nix-build defaults to using the the `<nixpkgs>` NIX_PATH entry in order to fetch dependencies; meaning that two users on different channels will get different results (for example, if you have the November 2017 channel but I have the October 2017 channel, the results may be different). With this patch, a user running $ nix-build will always use the exact same copy of nixpkgs to bootstrap the build, regardless of whatever channels the user has. This bootstrap mechanism does not even depend on an existing copy of Nixpkgs itself; e.g. it can work with a completely empty `NIX_PATH`. This is arguably anti-modular, but for end-user applications like bcachefs-tools, fixing the version of Nixpkgs is not normally a huge deal. Users who wish to use a different copy of Nixpkgs can provide this with an argument to nix-build directly, using the `nixpkgs` argument to the expression: $ nix-build --pure --arg nixpkgs 'import <nixpkgs> {}' This uses the `<nixpkgs>` provided inside your `NIX_PATH` environment variable to acquire dependencies, which by default is managed using `nix-channel`. If you have a copy of the Nixpkgs source code e.g. from a `git clone`, you may use that too by simply using `-I` to prepend your Nixpkgs to `NIX_PATH` (see `man nix-build` for more): $ nix-build --pure \ -I nixpkgs=$HOME/src/nixpkgs \ --arg nixpkgs 'import <nixpkgs> {}' Signed-off-by: Austin Seipp <aseipp@pobox.com>
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 00000000..82d4a852
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,45 @@
+{ nixpkgs ? (import ./nix/nixpkgs.nix)
+}:
+
+with nixpkgs;
+
+stdenv.mkDerivation rec {
+ name = "bcachefs-tools-${version}";
+ version = "git";
+
+ src = lib.cleanSource ./.; # NOTE: ignore .git, otherwise things get weird!
+
+ nativeBuildInputs = [ git pkgconfig ];
+ buildInputs =
+ [ liburcu libuuid libaio zlib attr keyutils
+ libsodium libscrypt
+ ];
+
+ patchPhase = ''
+ # ensure the mkfs and fsck scripts, which are just wrappers around
+ # 'bcachefs', are patched to refer to the right location inside the
+ # nix store. (you wouldn't expect built tools to call random outside
+ # utilities, in general, but the exact tools they were built with.)
+ #
+ # TODO FIXME: it would be better to fix this in the 'install' target,
+ # however, so this works with any bog-standard installation
+
+ substituteInPlace fsck.bcachefs --replace bcachefs $out/bin/bcachefs
+ substituteInPlace mkfs.bcachefs --replace bcachefs $out/bin/bcachefs
+ '';
+
+ enableParallelBuilding = true;
+ makeFlags =
+ [ "PREFIX=$(out)"
+ ];
+
+ meta = with stdenv.lib; {
+ description = "Userspace tools for bcachefs";
+ homepage = http://bcachefs.org;
+ license = licenses.gpl2;
+ platforms = platforms.linux;
+ maintainers =
+ [ "Kent Overstreet <kent.overstreet@gmail.com>"
+ ];
+ };
+}