summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAndy Whitcroft <apw@canonical.com>2010-08-03 13:46:27 +0100
committerLeann Ogasawara <leann.ogasawara@canonical.com>2010-08-20 16:02:52 -0700
commit3b8b8a73593e4bec76cc654d183110a130b2deba (patch)
tree976b31260ae78f4a8e3cf183370325893885d8a2 /debian
parent7c5a938262a87aa1c2ca05948935d95a29d710c0 (diff)
UBUNTU: debian -- include the debian packaging in the -source package
BugLink: http://bugs.launchpad.net/bugs/608674 The -source package is a bootstrap package allowing other packages which need the kernel source as part of their build process. This allows them to build depend on this package and have the source available. Currently this only includes the actual kernel source which we built from. In order to bootstrap compilers we consumers also need the rules used to build the kernel. Make a source version specific directory in /usr/src and add the debian and debian.master contents. Move the tarball into this directory as well to better match other packages. Finally include a symlink from the original tarball name for backwards compatibility. Signed-off-by: Andy Whitcroft <apw@canonical.com> Signed-off-by: Leann Ogasawara <leann.ogasawara@canonical.com>
Diffstat (limited to 'debian')
-rw-r--r--debian/rules.d/3-binary-indep.mk17
1 files changed, 14 insertions, 3 deletions
diff --git a/debian/rules.d/3-binary-indep.mk b/debian/rules.d/3-binary-indep.mk
index c670e5f3e010..d8f240782b3b 100644
--- a/debian/rules.d/3-binary-indep.mk
+++ b/debian/rules.d/3-binary-indep.mk
@@ -47,6 +47,7 @@ install-headers:
srcpkg = $(src_pkg_name)-source-$(release)
srcdir = $(CURDIR)/debian/$(srcpkg)/usr/src/$(srcpkg)
+balldir = $(CURDIR)/debian/$(srcpkg)/usr/src/$(srcpkg)/$(srcpkg)
install-source:
dh_testdir
dh_testroot
@@ -56,10 +57,20 @@ install-source:
ifeq ($(do_source_package_content),true)
find . -path './debian' -prune -o -path './$(DEBIAN)' -prune -o \
-path './.*' -prune -o -print | \
+ cpio -pd --preserve-modification-time $(balldir)
+ (cd $(srcdir); tar cf - $(srcpkg)) | bzip2 -9c > \
+ $(srcdir)/$(srcpkg).tar.bz2
+ rm -rf $(balldir)
+ find './debian' './$(DEBIAN)' \
+ -path './debian/linux-*' -prune -o \
+ -path './debian/$(src_pkg_name)-*' -prune -o \
+ -path './debian/build' -prune -o \
+ -path './debian/files' -prune -o \
+ -path './debian/stamps' -prune -o \
+ -path './debian/tmp' -prune -o \
+ -print | \
cpio -pd --preserve-modification-time $(srcdir)
- (cd $(srcdir)/..; tar cf - $(srcpkg)) | bzip2 -9c > \
- $(srcdir).tar.bz2
- rm -rf $(srcdir)
+ ln -s $(srcpkg)/$(srcpkg).tar.bz2 $(srcdir)/..
endif
install-tools: toolspkg = $(tools_common_pkg_name)