summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorXavier Boudet <x-boudet@ti.com>2012-02-22 14:20:22 +0100
committerXavier Boudet <x-boudet@ti.com>2012-09-10 14:50:24 +0200
commit7313d920d4d69f0d94caf86d4d778c69f4cb9097 (patch)
treeb4154ff8c1e02b5afdbef0bd9a558cdf178b8912 /debian
parent333a48d2b25face55061603c68446b707e7e3916 (diff)
LINARO: Use KBUILD_SCRIPTROOT to cross build scripts
Signed-off-by: Xavier Boudet <x-boudet@ti.com>
Diffstat (limited to 'debian')
-rw-r--r--debian/rules.d/2-binary-arch.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules.d/2-binary-arch.mk b/debian/rules.d/2-binary-arch.mk
index 1b26a39c45ce..c8fd73b51241 100644
--- a/debian/rules.d/2-binary-arch.mk
+++ b/debian/rules.d/2-binary-arch.mk
@@ -10,6 +10,8 @@ build_cd =
build_O = O=$(builddir)/build-$*
endif
+kbsr = $(builddir)/build-$*
+
$(stampdir)/stamp-prepare-%: config-prepare-check-%
@touch $@
$(stampdir)/stamp-prepare-tree-%: target_flavour = $*
@@ -175,7 +177,7 @@ endif
sed -e 's/.*CONFIG_DEBUG_INFO=.*/# CONFIG_DEBUG_INFO is not set/g' > \
$(hdrdir)/.config
chmod 644 $(hdrdir)/.config
- $(kmake) O=$(hdrdir) -j1 silentoldconfig prepare scripts
+ $(kmake) HOSTCC=$(CROSS_COMPILE)gcc KBUILD_SCRIPTROOT=$(kbsr) O=$(hdrdir) -j1 silentoldconfig prepare scripts
# We'll symlink this stuff
rm -f $(hdrdir)/Makefile
rm -rf $(hdrdir)/include2