summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Chinner <dchinner@redhat.com>2021-10-11 10:06:58 +1100
committerEryu Guan <guaneryu@gmail.com>2021-10-24 21:25:36 +0800
commit7b2e36d1bc6c2d116217bc14f182c5cdcab8ef5a (patch)
tree2ef8460ed8bff6cf817da9be7a2ed7a248101305 /configure.ac
parent74055e9afecdab30ba0588e9c71564106275b00e (diff)
fstests: autoconf has deprecated a bunch of macros
Latest debian unstable environment results in these build warnings: autoconf configure.ac:8: warning: The macro `AC_HEADER_STDC' is obsolete. configure.ac:8: You should run autoupdate. ./lib/autoconf/headers.m4:704: AC_HEADER_STDC is expanded from... configure.ac:8: the top level configure.ac:50: warning: The macro `AC_TRY_LINK' is obsolete. configure.ac:50: You should run autoupdate. ./lib/autoconf/general.m4:2920: AC_TRY_LINK is expanded from... m4/package_xfslibs.m4:95: AC_PACKAGE_NEED_XFSCTL_MACRO is expanded from... configure.ac:50: the top level configure.ac:63: warning: The macro `AC_TRY_LINK' is obsolete. configure.ac:63: You should run autoupdate. ./lib/autoconf/general.m4:2920: AC_TRY_LINK is expanded from... acinclude.m4:19: AC_PACKAGE_WANT_FALLOCATE is expanded from... configure.ac:63: the top level configure.ac:64: warning: The macro `AC_TRY_LINK' is obsolete. configure.ac:64: You should run autoupdate. ./lib/autoconf/general.m4:2920: AC_TRY_LINK is expanded from... acinclude.m4:32: AC_PACKAGE_WANT_OPEN_BY_HANDLE_AT is expanded from... configure.ac:64: the top level configure.ac:69: warning: The macro `AC_TRY_LINK' is obsolete. configure.ac:69: You should run autoupdate. ./lib/autoconf/general.m4:2920: AC_TRY_LINK is expanded from... m4/package_libcdev.m4:106: AC_HAVE_COPY_FILE_RANGE is expanded from... configure.ac:69: the top level configure.ac:107: warning: The macro `AC_CONFIG_HEADER' is obsolete. configure.ac:107: You should run autoupdate. ./lib/autoconf/status.m4:719: AC_CONFIG_HEADER is expanded from... configure.ac:107: the top level So, run autoupdate and then fix all the warnings. Signed-off-by: Dave Chinner <dchinner@redhat.com> Reviewed-by: Darrick J. Wong <djwong@kernel.org> Signed-off-by: Eryu Guan <guaneryu@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 6e5ab397..cbf83779 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,12 +1,11 @@
-AC_INIT([xfstests], [1.1.1])
+AC_INIT([xfstests],[1.1.2])
AC_CONFIG_MACRO_DIR([m4])
LT_INIT
AC_CONFIG_SRCDIR([src/xfsctl.c])
AC_PACKAGE_GLOBALS(xfstests)
AC_PACKAGE_UTILITIES(xfstests)
-AC_HEADER_STDC
- AC_CHECK_HEADERS([ assert.h \
+AC_CHECK_HEADERS([ assert.h \
bstring.h \
libgen.h \
dirent.h \
@@ -34,7 +33,7 @@ AC_HEADER_STDC
btrfs/ioctl.h \
cifs/ioctl.h \
sys/mman.h \
- ])
+])
AC_CHECK_HEADERS([xfs/xfs_log_format.h],,,[
#define _GNU_SOURCE
@@ -104,6 +103,6 @@ AC_CHECK_MEMBERS([struct btrfs_ioctl_vol_args_v2.subvolid], [], [], [[
#include <linux/btrfs.h>
]])
-AC_CONFIG_HEADER(include/config.h)
+AC_CONFIG_HEADERS([include/config.h])
AC_CONFIG_FILES([include/builddefs])
AC_OUTPUT