summaryrefslogtreecommitdiff
path: root/bch_bindgen/Cargo.toml
diff options
context:
space:
mode:
authorThomas Bertschinger <tahbertschinger@gmail.com>2024-02-04 13:49:23 -0700
committerKent Overstreet <kent.overstreet@linux.dev>2024-02-04 18:26:33 -0500
commitf6b619daad4e72329a52500299beac5721f6dd8f (patch)
tree3eabebf79698a31fc625559f62d0d393e52236eb /bch_bindgen/Cargo.toml
parentf154e6ed41e6080d7afe76d5d1209c5cae0acc12 (diff)
rust: update bindgen to 0.69.4; remove custom type modifications
This updates rust-bindgen to version 0.69.4 which includes the patch 199bee441ad0: "try to avoid #[repr(packed)] when align is needed". With this patch, bindgen generates code that is both ABI-correct and can be compiled by rustc, for 3 bcachefs types: - bkey - bch_extent_crc32 - bch_extent_ptr This allows us to remove the custom treatment for these three types. Signed-off-by: Thomas Bertschinger <tahbertschinger@gmail.com> Signed-off-by: Kent Overstreet <kent.overstreet@linux.dev>
Diffstat (limited to 'bch_bindgen/Cargo.toml')
-rw-r--r--bch_bindgen/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/bch_bindgen/Cargo.toml b/bch_bindgen/Cargo.toml
index fcc46685..63be4f3d 100644
--- a/bch_bindgen/Cargo.toml
+++ b/bch_bindgen/Cargo.toml
@@ -19,4 +19,4 @@ paste = "1.0.11"
[build-dependencies]
pkg-config = "0.3"
-bindgen = "0.69.2"
+bindgen = "0.69.4"