summaryrefslogtreecommitdiff
path: root/build.nix
diff options
context:
space:
mode:
authorWill Fancher <elvishjerricco@gmail.com>2024-01-21 17:16:51 -0500
committerWill Fancher <elvishjerricco@gmail.com>2024-01-23 02:38:20 -0500
commit8117fa732b4a4cd5e830d021e523c63725afcda3 (patch)
treec23e77263ba89234b29b4b1276ef363049d19e85 /build.nix
parent3da247cd20da37a4d3f4d957a30293261c0e38e2 (diff)
nix: fix build
Diffstat (limited to 'build.nix')
-rw-r--r--build.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/build.nix b/build.nix
index a37a6c6e..a7383d1b 100644
--- a/build.nix
+++ b/build.nix
@@ -33,7 +33,7 @@ in stdenv.mkDerivation {
udev
] ++ lib.optional fuseSupport fuse3;
- BCACHEFS_FUSE = if fuseSupport then "1" else "";
+ ${if fuseSupport then "BCACHEFS_FUSE" else null} = "1";
cargoRoot = ".";
# when git-based crates are updated, run:
@@ -49,7 +49,7 @@ in stdenv.mkDerivation {
makeFlags = [ "DESTDIR=${placeholder "out"}" "PREFIX=" "VERSION=${commit}" ];
dontStrip = true;
- checkPhase = "./bcachefs version";
+ checkPhase = "./target/release/bcachefs version";
doCheck = true;
meta = {