summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorThomas Mühlbacher <tmuehlbacher@posteo.net>2024-05-28 19:06:23 +0200
committerThomas Mühlbacher <tmuehlbacher@posteo.net>2024-05-28 19:32:53 +0200
commit7f156855177800d89073f57a064ab368f78b5584 (patch)
tree1f92e9a46378ab667beaca8e9a031e857e6b768d /flake.nix
parentb362f12add2b7307cf404ead3b0c4fc75b43422e (diff)
build(nix): minor tweaks
- rm unused function argument - `LIBCLANG_PATH` is superfluous here, this is already handled by `rustPlatform.bindgenHook` for us. - rustc is not directly needed in the `$PATH` for the build but it's good to have in the dev shell.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 1 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index fb1e420d..3cd44ec8 100644
--- a/flake.nix
+++ b/flake.nix
@@ -35,7 +35,6 @@
treefmt-nix,
fenix,
crane,
- flake-compat,
...
}:
flake-parts.lib.mkFlake { inherit inputs; } {
@@ -163,8 +162,6 @@
config.treefmt.build.devShell
];
- LIBCLANG_PATH = "${pkgs.clang.cc.lib}/lib";
-
# here go packages that aren't required for builds but are used for
# development, and might need to be version matched with build
# dependencies (e.g. clippy or rust-analyzer).
@@ -174,6 +171,7 @@
clang-tools
clippy
rust-analyzer
+ rustc
];
};