summaryrefslogtreecommitdiff
path: root/rust-src/Cargo.toml
diff options
context:
space:
mode:
authorThomas Bertschinger <tahbertschinger@gmail.com>2024-01-15 23:41:00 -0700
committerKent Overstreet <kent.overstreet@linux.dev>2024-01-16 01:46:41 -0500
commit0a284fc4ffcbb46f0a4b921415ef12a9c75fa05c (patch)
tree22aa82b7448833713ca975eb3c241f607742fc78 /rust-src/Cargo.toml
parent249bf7b9d446092e1b744c366b7e8c4563a437f0 (diff)
convert main() from C to Rust
This moves the main() function from C to Rust. It also updates the name of the Rust package from "bcachefs-rust" to "bcachefs-tools". Signed-off-by: Thomas Bertschinger <tahbertschinger@gmail.com> Signed-off-by: Kent Overstreet <kent.overstreet@linux.dev>
Diffstat (limited to 'rust-src/Cargo.toml')
-rw-r--r--rust-src/Cargo.toml8
1 files changed, 6 insertions, 2 deletions
diff --git a/rust-src/Cargo.toml b/rust-src/Cargo.toml
index 061d0641..2786fc76 100644
--- a/rust-src/Cargo.toml
+++ b/rust-src/Cargo.toml
@@ -1,12 +1,16 @@
[package]
-name = "bcachefs-rust"
+name = "bcachefs-tools"
version = "0.3.1"
authors = ["Yuxuan Shui <yshuiv7@gmail.com>", "Kayla Firestack <dev@kaylafire.me>", "Kent Overstreet <kent.overstreet@linux.dev>" ]
edition = "2021"
rust-version = "1.65"
+[[bin]]
+name = "bcachefs"
+path = "src/bcachefs.rs"
+
[lib]
-crate-type = ["staticlib"]
+name = "bcachefs"
[dependencies]
atty = "0.2.14"