summaryrefslogtreecommitdiff
path: root/rust-src/Cargo.toml
diff options
context:
space:
mode:
authorTruongSinh Tran-Nguyen <i@truongsinh.pro>2023-04-26 12:50:16 -0700
committerKent Overstreet <kent.overstreet@linux.dev>2023-04-26 17:46:23 -0400
commit47ec3ed6edb90c1117d0c79c382f03a3ed87c5ca (patch)
tree2aae100d0d553104b8276e8785865a7fc7b84991 /rust-src/Cargo.toml
parent4f6b28f54f09ee4498466d39cf550faeedd5614a (diff)
chore: logger for idiomatic style and expanded logging levels
Improve the Rust logger by adhering to idiomatic Rust conventions and incorporating additional logging levels: warn, debug, and trace. Signed-off-by: TruongSinh Tran-Nguyen <i@truongsinh.pro>
Diffstat (limited to 'rust-src/Cargo.toml')
-rw-r--r--rust-src/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/rust-src/Cargo.toml b/rust-src/Cargo.toml
index 64b195ca..92a3853f 100644
--- a/rust-src/Cargo.toml
+++ b/rust-src/Cargo.toml
@@ -9,7 +9,7 @@ crate-type = ["staticlib"]
[dependencies]
atty = "0.2.14"
-log = "0.4"
+log = { version = "0.4", features = ["std"] }
chrono = "0.4"
colored = "2"
clap = { version = "4.0.32", features = ["derive", "wrap_help"] }