summaryrefslogtreecommitdiff
path: root/rust-src/Cargo.toml
diff options
context:
space:
mode:
authorThomas Bertschinger <tahbertschinger@gmail.com>2024-01-15 23:41:02 -0700
committerKent Overstreet <kent.overstreet@linux.dev>2024-01-16 01:47:05 -0500
commitf5baaf48e3e82b1caf9f5cd1207d4d6feba3a2e5 (patch)
tree59f7b0e4667df7a9d3d5a45725f2aaab3e79b4c5 /rust-src/Cargo.toml
parentfb35dbfdc5a9446fbb856dae5542b23963e28b89 (diff)
move Rust sources to top level, C sources into c_src
This moves the Rust sources out of rust_src/ and into the top level. Running the bcachefs executable out of the development tree is now: $ ./target/release/bcachefs command or $ cargo run --profile release -- command instead of "./bcachefs command". Building and installing is still: $ make && make install Signed-off-by: Thomas Bertschinger <tahbertschinger@gmail.com> Signed-off-by: Kent Overstreet <kent.overstreet@linux.dev>
Diffstat (limited to 'rust-src/Cargo.toml')
-rw-r--r--rust-src/Cargo.toml27
1 files changed, 0 insertions, 27 deletions
diff --git a/rust-src/Cargo.toml b/rust-src/Cargo.toml
deleted file mode 100644
index 66d7bc6a..00000000
--- a/rust-src/Cargo.toml
+++ /dev/null
@@ -1,27 +0,0 @@
-[package]
-name = "bcachefs-tools"
-version = "0.3.1"
-authors = ["Yuxuan Shui <yshuiv7@gmail.com>", "Kayla Firestack <dev@kaylafire.me>", "Kent Overstreet <kent.overstreet@linux.dev>" ]
-edition = "2021"
-rust-version = "1.65"
-
-[[bin]]
-name = "bcachefs"
-path = "src/bcachefs.rs"
-
-[dependencies]
-atty = "0.2.14"
-log = { version = "0.4", features = ["std"] }
-colored = "2"
-clap = { version = "4.0.32", features = ["derive", "wrap_help"] }
-clap_complete = "4.3.2"
-anyhow = "1.0"
-libc = "0.2.69"
-udev = "0.7.0"
-uuid = "1.2.2"
-gag = "1.0.0"
-errno = "0.2"
-either = "1.5"
-rpassword = "4"
-bch_bindgen = { path = "bch_bindgen" }
-byteorder = "1.3"