summaryrefslogtreecommitdiff
path: root/rust-src/bch_bindgen/Cargo.toml
diff options
context:
space:
mode:
authorKayla Firestack <dev@kaylafire.me>2021-10-18 13:27:51 -0400
committerKayla Firestack <dev@kaylafire.me>2021-10-18 16:30:52 -0400
commit1f8fc31ddc1975a1f2e7c2fa8f7f611eab761680 (patch)
tree62eef03a32544a61c45665e6c4b4ea8014fd6fc8 /rust-src/bch_bindgen/Cargo.toml
parent7e97ef59bd30154776417748b6518ec43a3db2b9 (diff)
split mount into a library crate for rust reuse
update makefile to output shared library and rust build fix default.nix to properly get the binary name for `ln`ing - move binary to main.rs add rustfmt and gitignore files move build.rs file into bch_bindgen for reuse between projects add outputs to nix flake and checks add mount.toml to makefile
Diffstat (limited to 'rust-src/bch_bindgen/Cargo.toml')
-rw-r--r--rust-src/bch_bindgen/Cargo.toml26
1 files changed, 26 insertions, 0 deletions
diff --git a/rust-src/bch_bindgen/Cargo.toml b/rust-src/bch_bindgen/Cargo.toml
new file mode 100644
index 00000000..91cc77fe
--- /dev/null
+++ b/rust-src/bch_bindgen/Cargo.toml
@@ -0,0 +1,26 @@
+[package]
+name = "bch_bindgen"
+version = "0.1.0"
+authors = [ "Kayla Firestack <dev@kaylafire.me>", "Yuxuan Shui <yshuiv7@gmail.com>" ]
+edition = "2018"
+
+[lib]
+crate-type = ["lib"]
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+tracing = "0.1.26"
+anyhow = "1.0"
+udev = "0.4"
+uuid = "0.8"
+bitfield = "0.13"
+memoffset = "0.5"
+byteorder = "1.3"
+tracing-attributes = "0.1.15"
+libc = "0.2.69"
+gag = "1.0.0"
+
+
+[build-dependencies]
+pkg-config = "0.3"
+bindgen = { version = "0.59.1", default-features = false }