summaryrefslogtreecommitdiff
path: root/rust-src/bch_bindgen/Cargo.toml
diff options
context:
space:
mode:
authorKent Overstreet <kent.overstreet@linux.dev>2023-11-02 16:44:59 -0400
committerKent Overstreet <kent.overstreet@linux.dev>2023-11-02 16:44:59 -0400
commit37ee7f0591f28ce285eedc0a8c21bbd65e9a52d2 (patch)
treedda229e1e5f322952b9e4288aab2cd2e81e55073 /rust-src/bch_bindgen/Cargo.toml
parent0a08ddf78c9cf4b6671ba64b049c37da64233f4f (diff)
Update, slim down rust dependencies
Signed-off-by: Kent Overstreet <kent.overstreet@linux.dev>
Diffstat (limited to 'rust-src/bch_bindgen/Cargo.toml')
-rw-r--r--rust-src/bch_bindgen/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/rust-src/bch_bindgen/Cargo.toml b/rust-src/bch_bindgen/Cargo.toml
index cb341eef..da6654c2 100644
--- a/rust-src/bch_bindgen/Cargo.toml
+++ b/rust-src/bch_bindgen/Cargo.toml
@@ -9,7 +9,7 @@ crate-type = ["lib"]
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-chrono = "0.4"
+chrono = { version = "0.4", default-features = false }
colored = "2"
anyhow = "1.0"
udev = "0.7.0"
@@ -18,7 +18,7 @@ bitfield = "0.14.0"
memoffset = "0.8.0"
byteorder = "1.3"
libc = "0.2.69"
-gag = "1.0.0"
+gag = { version = "1.0.0", default-features = false }
bitflags = "1.3.2"
paste = "1.0.11"