summaryrefslogtreecommitdiff
path: root/rust-src/bch_bindgen/Cargo.toml
diff options
context:
space:
mode:
authorAlexander Fougner <fougner89@gmail.com>2023-01-12 20:35:23 +0100
committerAlexander Fougner <fougner89@gmail.com>2023-01-15 22:20:13 +0100
commit87243efa5c792f72be0bcea2fdf0c4335d59c2ec (patch)
treeb646133f468fef83ed4ec5520eeb9dd5ac96eb04 /rust-src/bch_bindgen/Cargo.toml
parentccaca683b22170b633e3840fcc913c8a9ce30d51 (diff)
rust: support fstab style mount
- add support for fstab format, UUID=<uuid> - structopt is no longer actively maintained, replace with clap v4 which support everything structopt can and more. - update dependencies Signed-off-by: Alexander Fougner <fougner89@gmail.com>
Diffstat (limited to 'rust-src/bch_bindgen/Cargo.toml')
-rw-r--r--rust-src/bch_bindgen/Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/rust-src/bch_bindgen/Cargo.toml b/rust-src/bch_bindgen/Cargo.toml
index 37a56273..7a619117 100644
--- a/rust-src/bch_bindgen/Cargo.toml
+++ b/rust-src/bch_bindgen/Cargo.toml
@@ -11,10 +11,10 @@ crate-type = ["lib"]
[dependencies]
tracing = "0.1.26"
anyhow = "1.0"
-udev = "0.4"
-uuid = "0.8"
-bitfield = "0.13"
-memoffset = "0.5"
+udev = "0.7.0"
+uuid = "1.2.2"
+bitfield = "0.14.0"
+memoffset = "0.8.0"
byteorder = "1.3"
tracing-attributes = "0.1.15"
libc = "0.2.69"