summaryrefslogtreecommitdiff
path: root/rust-src/bch_bindgen/Cargo.toml
diff options
context:
space:
mode:
authorAlexander Fougner <fougner89@gmail.com>2023-01-16 17:08:52 +0100
committerAlexander Fougner <fougner89@gmail.com>2023-01-18 06:47:46 +0100
commit8accfdc3c596bfe5cbd10dac3f1650192981eb17 (patch)
treee93535eb6ded70806cc7518fb453448d569abaa1 /rust-src/bch_bindgen/Cargo.toml
parent20aecb42d8d1c869b17b38b979b9f2f7cbd2ca34 (diff)
rust: replace tracing with logger
tracing framework is a overengineered for simple mount helper. Add a few very barebone logging macros to allow configurable verbosity and colorized output with a small footprint. Signed-off-by: Alexander Fougner <fougner89@gmail.com>
Diffstat (limited to 'rust-src/bch_bindgen/Cargo.toml')
-rw-r--r--rust-src/bch_bindgen/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/rust-src/bch_bindgen/Cargo.toml b/rust-src/bch_bindgen/Cargo.toml
index 7a619117..ce15fe0a 100644
--- a/rust-src/bch_bindgen/Cargo.toml
+++ b/rust-src/bch_bindgen/Cargo.toml
@@ -9,14 +9,14 @@ crate-type = ["lib"]
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-tracing = "0.1.26"
+chrono = "0.4"
+colored = "2"
anyhow = "1.0"
udev = "0.7.0"
uuid = "1.2.2"
bitfield = "0.14.0"
memoffset = "0.8.0"
byteorder = "1.3"
-tracing-attributes = "0.1.15"
libc = "0.2.69"
gag = "1.0.0"