summaryrefslogtreecommitdiff
path: root/rust-src/bch_bindgen/Cargo.toml
diff options
context:
space:
mode:
authorThomas Bertschinger <tahbertschinger@gmail.com>2024-01-15 23:41:02 -0700
committerKent Overstreet <kent.overstreet@linux.dev>2024-01-16 01:47:05 -0500
commitf5baaf48e3e82b1caf9f5cd1207d4d6feba3a2e5 (patch)
tree59f7b0e4667df7a9d3d5a45725f2aaab3e79b4c5 /rust-src/bch_bindgen/Cargo.toml
parentfb35dbfdc5a9446fbb856dae5542b23963e28b89 (diff)
move Rust sources to top level, C sources into c_src
This moves the Rust sources out of rust_src/ and into the top level. Running the bcachefs executable out of the development tree is now: $ ./target/release/bcachefs command or $ cargo run --profile release -- command instead of "./bcachefs command". Building and installing is still: $ make && make install Signed-off-by: Thomas Bertschinger <tahbertschinger@gmail.com> Signed-off-by: Kent Overstreet <kent.overstreet@linux.dev>
Diffstat (limited to 'rust-src/bch_bindgen/Cargo.toml')
-rw-r--r--rust-src/bch_bindgen/Cargo.toml22
1 files changed, 0 insertions, 22 deletions
diff --git a/rust-src/bch_bindgen/Cargo.toml b/rust-src/bch_bindgen/Cargo.toml
deleted file mode 100644
index 33090ae9..00000000
--- a/rust-src/bch_bindgen/Cargo.toml
+++ /dev/null
@@ -1,22 +0,0 @@
-[package]
-name = "bch_bindgen"
-version = "0.1.0"
-authors = [ "Kayla Firestack <dev@kaylafire.me>", "Yuxuan Shui <yshuiv7@gmail.com>", "Kent Overstreet <kent.overstreet@linux.dev>" ]
-edition = "2021"
-
-[lib]
-crate-type = ["lib"]
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
-
-[dependencies]
-anyhow = "1.0"
-uuid = "1.2.2"
-bitfield = "0.14.0"
-memoffset = "0.8.0"
-byteorder = "1.3"
-bitflags = "1.3.2"
-paste = "1.0.11"
-
-[build-dependencies]
-pkg-config = "0.3"
-bindgen = { git = "https://evilpiepirate.org/git/rust-bindgen.git", default-features = false }