summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorDaniel B. Hill <daniel@gluo.nz>2022-01-12 00:26:05 +1300
committerKent Overstreet <kent.overstreet@gmail.com>2022-05-30 22:26:27 -0400
commit962390c0b2e90c1c85abfe69b8b76fd7ef3925ee (patch)
tree12afc57ec32fda70ab156311c91d4219c15b0bab /shell.nix
parent03ed64edc88343665ebd38eaaeebeba0229b1974 (diff)
Simplify Nix(OS) development
Signed-off-by: Daniel B. Hill <daniel@gluo.nz>
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 00000000..fc7929d1
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,18 @@
+{ kversion ? "linux_5_15"
+, pkgs ? import <nixpkgs> {} }:
+
+with pkgs;
+
+let
+ tools = pkgs.callPackage ./default.nix { doCheck = false ;} ;
+in
+mkShell {
+ buildInputs = [
+ linuxKernel.packages.${kversion}.perf
+ gdb
+ ccls # code completion in neovim/emacs
+ ];
+ inputsFrom = [
+ tools
+ ];
+}