summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorDaniel Hill <daniel@gluo.nz>2022-11-25 12:47:29 +1300
committerDaniel Hill <daniel@gluo.nz>2023-01-03 16:58:55 +1300
commit9a44c6d4d020035f25baf74b1f7986b3221a274e (patch)
tree5d40fc996aa15176c9f75e45fc738200f25eb27a /shell.nix
parent9d6040c8b60d10f901141df9d739005f3fe0326e (diff)
nix: overhaul build system.
Removed outdated overlay. Simply build tooling using bingenHook and propagated*Inputs Signed-off-by: Daniel Hill <daniel@gluo.nz>
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index fc7929d1..24a6e0a9 100644
--- a/shell.nix
+++ b/shell.nix
@@ -10,7 +10,10 @@ mkShell {
buildInputs = [
linuxKernel.packages.${kversion}.perf
gdb
- ccls # code completion in neovim/emacs
+ # lsp code completion in neovim/emacs
+ clangd
+ rust-analyzer
+ rnix-lsp
];
inputsFrom = [
tools