summaryrefslogtreecommitdiff
path: root/bch_bindgen/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'bch_bindgen/Cargo.toml')
-rw-r--r--bch_bindgen/Cargo.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/bch_bindgen/Cargo.toml b/bch_bindgen/Cargo.toml
new file mode 100644
index 00000000..33090ae9
--- /dev/null
+++ b/bch_bindgen/Cargo.toml
@@ -0,0 +1,22 @@
+[package]
+name = "bch_bindgen"
+version = "0.1.0"
+authors = [ "Kayla Firestack <dev@kaylafire.me>", "Yuxuan Shui <yshuiv7@gmail.com>", "Kent Overstreet <kent.overstreet@linux.dev>" ]
+edition = "2021"
+
+[lib]
+crate-type = ["lib"]
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+anyhow = "1.0"
+uuid = "1.2.2"
+bitfield = "0.14.0"
+memoffset = "0.8.0"
+byteorder = "1.3"
+bitflags = "1.3.2"
+paste = "1.0.11"
+
+[build-dependencies]
+pkg-config = "0.3"
+bindgen = { git = "https://evilpiepirate.org/git/rust-bindgen.git", default-features = false }