summaryrefslogtreecommitdiff
path: root/build.nix
diff options
context:
space:
mode:
Diffstat (limited to 'build.nix')
-rw-r--r--build.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/build.nix b/build.nix
index 831c7e9f..a37a6c6e 100644
--- a/build.nix
+++ b/build.nix
@@ -35,12 +35,12 @@ in stdenv.mkDerivation {
BCACHEFS_FUSE = if fuseSupport then "1" else "";
- cargoRoot = "rust-src";
+ cargoRoot = ".";
# when git-based crates are updated, run:
# nix run github:Mic92/nix-update -- --version=skip --flake default
# to update the hashes
cargoDeps = rustPlatform.importCargoLock {
- lockFile = "${src}/rust-src/Cargo.lock";
+ lockFile = "${src}/Cargo.lock";
outputHashes = {
"bindgen-0.64.0" = "sha256-GNG8as33HLRYJGYe0nw6qBzq86aHiGonyynEM7gaEE4=";
};