summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorjkar8572 <jkar8572>2001-09-26 12:26:11 +0000
committerjkar8572 <jkar8572>2001-09-26 12:26:11 +0000
commit570ff1d772f4b2d0a73025c547e46e82ceb79eaa (patch)
tree56f536fb06c9557096635c05e00dfc8d9649ead1 /configure.in
parent48448ca24e00e530e59d774bfdb3c2a76616330c (diff)
Fixed detection of RH 7.1 kernel not to make problems on older kernels.
Utilities now use shared locks when opening files read-only. Changed naming of Q_GETSTATS as they would be no longer in kernel.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e98e3aa..2af1c95 100644
--- a/configure.in
+++ b/configure.in
@@ -34,6 +34,15 @@ if test "x$with_ext2direct" != "xno"; then
EXT2LIBS=""
else
with_ext2direct="yes"
+ AC_MSG_CHECKING([for ext2_ino_t])
+ have_ext2_ino_t="no"
+ AC_EGREP_HEADER(ext2_ino_t, ext2fs/ext2fs.h, have_ext2_ino_t="yes")
+ if test "x$have_ext2_ino_t" != "xyes"; then
+ AC_MSG_RESULT([not found])
+ else
+ AC_MSG_RESULT([found])
+ CFLAGS="-DHAVE_EXT2_INO_T $CFLAGS"
+ fi
fi
fi
if test "x$with_ext2direct" = "xyes"; then