summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorjkar8572 <jkar8572>2001-04-05 08:26:56 +0000
committerjkar8572 <jkar8572>2001-04-05 08:26:56 +0000
commit7ec003b82d056fa150924f15da0d0d0e353cf041 (patch)
treea5bf9ec4709b69031b3c9977893b45cbbfa3de8e /configure.in
parent62e95f2d20146d266719badea3074a2416b71664 (diff)
Added EXT2DIRECT as configurable option.
Fixed bug in quotacheck -c option. Fixed bug in RPC implementation.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in44
1 files changed, 32 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index bcabb3a..84606f3 100644
--- a/configure.in
+++ b/configure.in
@@ -7,8 +7,38 @@ AC_HEADER_STDC
AC_PROG_INSTALL
dnl Checks for libraries.
-AC_CHECK_LIB(com_err, com_err)
-AC_CHECK_LIB(ext2fs, ext2fs_initialize)
+AC_ARG_WITH(ext2direct,
+ [ --with-ext2direct=[yes/no/try] Enable alternative format used by edquota [default=try].],
+ ,
+ with_ext2direct="try")
+if test "x$with_ext2direct" != "xno"; then
+ AC_CHECK_LIB(com_err, com_err)
+ AC_CHECK_LIB(ext2fs, ext2fs_initialize)
+ if test "${ac_cv_lib_com_err_com_err}" != "yes" -o "${ac_cv_lib_ext2fs_ext2fs_initialize}" != "yes"; then
+ if test "x$with_ext2direct" = "xyes"; then
+ AC_MSG_ERROR([Ext2 direct support required but libraries not found.])
+ else
+ AC_MSG_WARN([Ext2 direct support won't be compiled. Libraries not found.])
+ fi
+ with_ext2direct="no"
+ else
+ AC_CHECK_HEADER(ext2fs/ext2fs.h,ext2fshead="yes")
+ if test "x$ext2fshead" != "xyes"; then
+ if test "x$with_ext2direct" = "xyes"; then
+ AC_MSG_ERROR([Ext2 direct support required but header files not found.])
+ else
+ AC_MSG_WARN([Ext2 direct support won't be compiled. Header files not found.])
+ fi
+ with_ext2direct="no"
+ else
+ with_ext2direct="yes"
+ fi
+ fi
+ if test "x$with_ext2direct" = "xyes"; then
+ EXT2_DIRECT="-DEXT2_DIRECT"
+ AC_SUBST(EXT2_DIRECT)
+ fi
+fi
EXT2LIBS=${LIBS}
AC_SUBST(EXT2LIBS)
LIBS=""
@@ -16,16 +46,6 @@ LIBS=""
AC_CHECK_LIB(nsl, main)
AC_CHECK_LIB(wrap, main)
-if test ${ac_cv_lib_com_err_com_err} = yes &&
- test ${ac_cv_lib_ext2fs_ext2fs_initialize} = yes; then
- AC_CHECK_HEADER(ext2fs/ext2fs.h,, [
- echo 'ERROR: could not find ext2fs/ext2fs.h - missing ext2 package'
- exit 1
- ])
- EXT2_DIRECT="-DEXT2_DIRECT"
- AC_SUBST(EXT2_DIRECT)
-fi
-
if test ${ac_cv_lib_wrap_main} = yes; then
AC_CHECK_HEADER(tcpd.h,, [
echo 'ERROR: could not find tcpd.h - missing TCP wrappers package'