summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorjkar8572 <jkar8572>2001-05-02 09:32:22 +0000
committerjkar8572 <jkar8572>2001-05-02 09:32:22 +0000
commit84ec12aa207cb8d5323b63847bfd8115881f2886 (patch)
tree9533951fedda68167081028741a9ec3fd8ad547b /configure.in
parent9c4a512419c660c0513db48e038169167e3e7d25 (diff)
Added mntopt.h to dependencies in Makefile.in.
Fixed MNTTYPE_REISER to proper string. sprintf->snprintf Merged Marco's patch with errstr(), configurable BSD behaviour Fixed bug in quota detection IO code now opens file only RO if possible. IO code now doesn't open file if not required. Fixed bug in quotaon. Updated all manpages.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 84606f3..4775238 100644
--- a/configure.in
+++ b/configure.in
@@ -71,6 +71,10 @@ AC_ARG_ENABLE(rpcsetquota,
[ --enable-rpcsetquota=[yes/no] Use RPC for setting quotas [default=yes].],
,
enable_rpcsetquota="yes")
+AC_ARG_ENABLE(bsd_behaviour,
+ [ --enable-bsd_behaviour=[yes/no] Mimic BSD behaviour [default=yes].],
+ ,
+ enable_bsd_behaviour="yes")
AC_ARG_ENABLE(libefence,
[ --enable-libefence=[yes/no] Use Electric Fence memory checks [default=no].],
,
@@ -85,6 +89,9 @@ fi
if test "$enable_rpcsetquota" = "yes" ; then
CFLAGS="-DRPC_SETQUOTA $CFLAGS"
fi
+if test "$enable_bsd_behaviour" = "yes" ; then
+ CFLAGS="-DBSD_BEHAVIOUR $CFLAGS"
+fi
if test "$enable_libefence" = "yes" ; then
LIBMALLOC="/usr/lib/libefence.a"
fi