summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorjkar8572 <jkar8572>2001-08-08 14:01:50 +0000
committerjkar8572 <jkar8572>2001-08-08 14:01:50 +0000
commitd53de898f784e71fe6ecb157be86b644b092e88b (patch)
treefd15ac0c636da35f73215f61701c286041443ed2 /configure.in
parent5f7affb337573a9679d9a5205a697003f9b51979 (diff)
Made configure script work right of systems with e2fslib but without ext2fs.h.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 4775238..e98e3aa 100644
--- a/configure.in
+++ b/configure.in
@@ -12,8 +12,8 @@ AC_ARG_WITH(ext2direct,
,
with_ext2direct="try")
if test "x$with_ext2direct" != "xno"; then
- AC_CHECK_LIB(com_err, com_err)
- AC_CHECK_LIB(ext2fs, ext2fs_initialize)
+ AC_CHECK_LIB(com_err, com_err, EXT2LIBS="-lcom_err $EXT2LIBS")
+ AC_CHECK_LIB(ext2fs, ext2fs_initialize, EXT2LIBS="-lext2fs $EXT2LIBS",, "-lcom_err")
if test "${ac_cv_lib_com_err_com_err}" != "yes" -o "${ac_cv_lib_ext2fs_ext2fs_initialize}" != "yes"; then
if test "x$with_ext2direct" = "xyes"; then
AC_MSG_ERROR([Ext2 direct support required but libraries not found.])
@@ -21,6 +21,7 @@ if test "x$with_ext2direct" != "xno"; then
AC_MSG_WARN([Ext2 direct support won't be compiled. Libraries not found.])
fi
with_ext2direct="no"
+ EXT2LIBS=""
else
AC_CHECK_HEADER(ext2fs/ext2fs.h,ext2fshead="yes")
if test "x$ext2fshead" != "xyes"; then
@@ -30,6 +31,7 @@ if test "x$with_ext2direct" != "xno"; then
AC_MSG_WARN([Ext2 direct support won't be compiled. Header files not found.])
fi
with_ext2direct="no"
+ EXT2LIBS=""
else
with_ext2direct="yes"
fi
@@ -39,9 +41,7 @@ if test "x$with_ext2direct" != "xno"; then
AC_SUBST(EXT2_DIRECT)
fi
fi
-EXT2LIBS=${LIBS}
AC_SUBST(EXT2LIBS)
-LIBS=""
AC_CHECK_LIB(nsl, main)
AC_CHECK_LIB(wrap, main)