summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9a90a5b..76d2cdd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -206,6 +206,15 @@ AS_IF([test x"$enable_rpc" != "xno"], [
])
build_rpc="no"
])
+
+ PKG_CHECK_MODULES([TIRPC], [libtirpc], [], [
+ AS_IF([test x"$enable_rpc" = "xyes"], [
+ AC_MSG_ERROR([could not locate required libtirpc])
+ ], [
+ AC_MSG_WARN([libtirpc not found])
+ ])
+ build_rpc="no"
+ ])
AS_IF([test x"$build_rpc" != "xno"], [
AC_DEFINE([RPC], 1, [Support for RPC])