summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2d6445d..5c0f24d 100644
--- a/configure.in
+++ b/configure.in
@@ -116,6 +116,15 @@ AC_ARG_ENABLE(libefence,
,
enable_libefence="no")
+AC_ARG_ENABLE(nls,
+ [ --enable-nls=[yes/no] Enable gettext [dafault=yes].],
+ ,
+ enable_nls="yes")
+AC_ARG_ENABLE(rootsbin,
+ [ --enable-rootsbin=[yes/no] Use /sbin for some important binaries regardless $prefix [default=no].],
+ ,
+ enable_rootsbin="no")
+
if test "$enable_altformat" = "yes" ; then
CFLAGS="-DALT_FORMAT $CFLAGS";
fi
@@ -134,6 +143,17 @@ fi
if test "$enable_libefence" = "yes" ; then
LIBMALLOC="/usr/lib/libefence.a"
fi
+if test "$enable_nls" = "yes" ; then
+ CFLAGS="-D__GETTEXT__ $CFLAGS"
+ INSTMO="inst_mo"
+fi
+if test "$enable_rootsbin" = "yes" ; then
+ ROOTSBIN="/sbin"
+else
+ ROOTSBIN='$(prefix)/sbin'
+fi
AC_SUBST(LIBMALLOC)
+AC_SUBST(INSTMO)
+AC_SUBST(ROOTSBIN)
AC_OUTPUT(Makefile)